End of PHP < 5.6 support on HIS servers

As of Jan 1 2018, HIS will stop supporting PHP versions <5.6, which have reached their end-of-life.
The only PHP versions that will be supported on HIS web servers or VPS will be:

5.6: Security Updates until 31 Dec. 2018
7.0: Active Support until Dec. 3 2017, Security Updates until Dec. 3 2018
7.1: Active Support until Dec. 1 2018, Security Updates until Dec. 1 2019

You should upgrade your web site custom scripts or web applications and web sites to PHP 7 or 7.1 ASAP.

Check your site(s) and any PHP scripts on your account for any outdated code references to the old PHP versions that may have been deprecated in the newer versions of PHP.
Check which functions were deprecated with each PHP version upgrade, see: http://php.net/manual/en/appendices.php

If you are using a CMS, such as WordPress,Joomla, Drupal or any other actively maintained PHP script that you didn’t write, you will need to make sure your main Application installation and any Themes or Plugins are available for the latest CMS versions and support the latest PHP versions.
Some may need to be replaced.
Remove any theme or plugin that is no longer supported by the developers as it has not been updated to use new PHP versions or functions and could be susceptible to vulnerabilities in their code could render your site offline or receive an error message, or could be hacked.

Upon request, we can copy your web site to a new server so you can test it under the new PHP and upgrade it while keeping the live web site on its old server.


Properties ID: 000497   Views: 49   Updated: 16 days ago